Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Renaming copying or starting new files/projects

in Bugs Posts: 22

When I try to start a new project, duplicate one or rename a project, Codea freezes.
Starting a new project starts well, but when I go to type in the name it has frozen. The only way out is to swipe Codea off the screen. Existing files open as usual.

I can get around this by working in the IOS files app. When I installed Codea it installed in the files app. I can copy a Codea file like any other file then rename the file to create a new one.

Could this be a bug?


  • dave1707dave1707 Mod
    Posts: 9,977

    Have you tried powering off your device and starting it again. I can’t think of why Codea isn’t letting you do anything. What version of iOS and Codea are you running.

  • I have IOS 14.0.1
    Codea 3.2.6 it upgraded on 2 - 10 - 2020
    I tried restarting the iPad. I was able to create a new project once then not again. I was unable to rename at all.

  • dave1707dave1707 Mod
    Posts: 9,977

    Do you have the latest version of Codea from the App Store. Also, what device are you running Codea on.

  • I think I have the latest version of Codea. An upgrade came through on 2nd of October. When I go to Codea on the App Store my only choice is to open.
    My iPad is an IPad 5th generation Model 1823
    None of this was happening before the IOS 14 upgrade.

  • Posts: 2,689
    @congokjt - when you say iOS 14 do you mean iPadOS 14 ?
  • Yes that’s correct.

  • dave1707dave1707 Mod
    Posts: 9,977

    Are you using an external keyboard or the on screen keyboard.

  • The screen keyboard

  • dave1707dave1707 Mod
    Posts: 9,977

    How much free space do you have. I can’t think of any reason why you’re having so much trouble.

  • Posts: 2,689
    Are there any settings in General>Applications>Codea that could influence this ? or even system settings in the Codea menu - font etc.
  • I can’t see any settings that would affect anything. I have the ”.” shortcut turned off. I have 55.8 storage used out of 128 go.
    Also I find the cursor or whatever it is called very jumpy in Codea, sometimes needing several taps before it appears or sometimes I have to go to anther line and tap then drag down.
    I would doubt there is anything wrong with the iPad, it works fine with all other apps.

  • dave1707 in response to your comment
    I’m not having too much trouble. If I work in the file app all is good.

  • dave1707dave1707 Mod
    Posts: 9,977

    @congokjt Do what you need to do in the Files app, but when you have free time, try a lot of different things in Codea. Maybe you can find some kind of pattern as to the problems you’re having. The more things you find, the better chance of solving what’s happening.

  • Ok will do

  • Hi again
    The situation has worsened. The play button stopped working on some of my projects. I did a system reset of my iPad and nothing I deleted a reinstalled Codea. All my projects disappeared as expected. My only choice is to copy one of the examples, and clear it.
    They have their own icons and I don’t know how to change them.

  • edited October 2020 Posts: 2,689
    @congokjt You change project icons by running them and touching the camera icon in the bottom left tools icons. From there you can snapshot the screen as a new icon.

    Before you do though, you need to duplicate the examples by long pressing on it to get an example copy. Then run that to generate a new icon screen, and long press the copy to rename it to what you want.

    Does that work for you?
  • edited October 2020 Posts: 22

    Thanks. Bri_G
    I do know how to duplicate and rename but it isn’t working.
    The screen freezes when I rename or start a new project as I originally stated. The only way is to duplicate and rename from the file app.
    As for the icon, using the camera gave me a screen shot and that became the icon. I guess I could get my project to draw something first.
    How do I change to the default icon.
    What I would really like is to get Codea to work properly again.

  • If no one else is having this kind of trouble it must be something in my settings, or a problem with the iPad itself. I have no unusual settings and I have done a reset. None of my other apps have any problems at all,
    Any ideas about something in my iPads settings?

  • dave1707dave1707 Mod
    Posts: 9,977

    @Simeon Can you give any suggestions as to what’s happening in this discussion. I can’t think of anything else to try.

  • Likewise. Here is what’s happening. When I try to start a new project the screen or rename a project the screen freezes and I can’t type anything in. I have already reloaded Codea, and reset the iPad to factory settings.
    I can still create a new project by copying one of the examples in the iPad file app.
    Everything used to work fine.
    I can’t see anything in my settings that would cause this.

  • edited October 2020 Posts: 2,689

    @congokjt - have you considered re-installing your iPadOS, thinking it may have been corrupted. Then reinstalling Codea (the current one) then, if that fails, possibly installing an older version of Codea?

    Could you record a short video - I know the touches aren’t visible but we may pick up on screen features and you could give a text timeline of the video.

  • Thanks for your response Bri_G.
    I think I have solved this problem.
    I went to settings, general, keyboard. The shortcuts option was causing the problem. As soon as I turned off all the options Codea started functioning properly. By a process of elimination the shortcuts option was causing the problem. There must be a clash with it.
    I haven’t tried the shortcuts, introduced in IOS 12, but I believe they can be very handy.
    When I get a chance I will try and eliminate the other problem with the jumpy cursor. I mentioned it in my post on Oct 12.

  • Posts: 2,689

    @congokjt - that’s weird, never looked at the keyboard settings for iOS/iPadOS but just checked now and all the options are set on with my pad. Have you added an external keyboard or another keyboard type?

  • edited October 2020 Posts: 2,689

    @Simeon - this is probably a feature of the last post I made with the cursor moving up a line on the last line when the keyboard is in view. But when I copy and paste code into a project the cursor ends up on the last line ie the end statement - but it is placed between the ‘n’ and the ‘d’. Looks like there are additional control codes present after pasting that move the cursor and, when you tap to try to get to the end the cursor jumps up a line.

    Could this be a feature of iPadOS change with the keyboard settings like the problem encountered by @congokjt ?

  • Hi Br_G.
    To answer your 6.06 pm post...
    I only use the onscreen keyboard. All the keyboards options were on with mine too. I sometimes take out the ”.” when using a songbook app.

    The “jumping cursor” situation improved noticeably after I turned off the shortcuts option. I tried them all but none of the others made a difference.
    I would guess that the clash with the shortcuts option may be a bug in Codea but what would I know.

  • dave1707dave1707 Mod
    Posts: 9,977

    @congokjt I don’t think it’s a Codea bug. I have all the keyboard options turned on except for the “.” one. That’s the way it’s been for every iPad I’ve used since I started using Codea. Something else is going on that we’re not thinking of and it’s hard to figure out since we don’t have your iPad to see. That’s why it’s important for you to try different things to see what happens.

    You said your iPad is an IPad 5th generation Model 1823 on iOS 14.

    Question for everyone reading this.
    Does anyone else who uses that iPad model have similar problems.

  • Hi dave1707
    I have tried a couple of things. As I said previously I have tried all the other keyboard settings and none have any effect.

    Also I have tried putting the shortcuts option back on. It has no effect on the other coding apps I use.

  • Posts: 52

    I have the same problem with Add New Project. I wanted to add a project (to test a code snippet from @dave1707!) and the screen froze on the field to give it a name. I use the latest Codea and almost the latest iPadOS, 14.0.1. My iPad is an iPad Pro, about 3 years old.

    As @congokjt found, when I turned off the keyboard shortcuts option, it worked fine. As soon as I turned that back on the problem came back.

  • dave1707dave1707 Mod
    Posts: 9,977

    @Ceres Is your iPad Pro an iPad Pro 1. I have an iPad Pro 1 and I tried different things and I couldn’t get it to freeze. I checked my keyboard settings and I have Keyboards set to 2 which is English (US) and Emoji. Text Replacement has omw. All the settings are on except "." which is off. Enable Dictation is off. Memoji Stickers is on. Can you describe exactly what you’re keying and pressing when it hangs then I can try the same thing. I assume when it hangs, pressing everything on the screen does nothing.

  • Posts: 52

    Sorry I didn't see this before: I have an iPad Pro 9.7 inch

Sign In or Register to comment.