Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Codea 3.3 (265)

dave1707dave1707 Mod
edited April 4 in Beta Posts: 9,415

@Simeon Running the latest version and I’ve had 2 times where I pasted some code into a project and had a red line error show. The last one I remember was on an end statement. I didn’t see any reason for the error so I tried to run the code anyways and it ran. When I exited the code back to the editor, the error was still there. I deleted the line and rekeyed the “end” and the error was gone. Will keep an eye out for it and see if I can find a reason.


  • dave1707dave1707 Mod
    Posts: 9,415

    @Simeon Here’s something I can reproduce. Create a new project. In function setup() key saveProjectTab(“test”,”— qwerty”). Run the code. Exit back to the editor. The tab will be created, but the Main tab won’t have the updated code in it.

    PS. The — in front of qwerty are - for comments.

  • dave1707dave1707 Mod
    Posts: 9,415

    @Simeon I also tried the saveProjectTab problem in version 3.2.11 (256) on another iPad and had the same results. The code disappeared.

  • Posts: 644

    @Simeon, funny one...if i do a search for a particular file in the Codea main page and my selected files are listed and then i press on a file: I only get the options to Duplicate and Delete. The options to Rename, Export, Make Template are absent?

  • edited April 9 Posts: 2,348

    @Simeon - installed @UberGoober graphics from topdown shooter (ex Xavier) to Dropbox. Told Dropbox to sync several times, each time it told me it had resynced 128 files - so it looks like there is a clash with the synchronisation. Then closed the Dropbox filer window to give the project window background with the open ‘button’ in the top left corner. I had to tap that to set up the project icons. Was that intentional?

  • SimeonSimeon Admin Mod
    Posts: 5,693

    @piinthesky ah that's a bug, will note it down

Sign In or Register to comment.